Skip to main content
公式の Diversion プラグインは、バージョン 2025.1 以降の JetBrains IDE に、バージョン管理システムとして Diversion を追加します。

前提条件

  • 同じコンピューターに Diversion がインストールされ、サインインしていること。クイックスタートを参照してください。プラグインは dv CLI と Diversion のサインイン情報を使用します。
  • コンピューターにクローンした Diversion リポジトリ。IDE からクローンすることもできます (下記参照)。

プラグインをインストールする

  1. IDE で Settings → Plugins → Marketplace を開きます。
  2. Diversion を検索して Install をクリックします。IDE から求められた場合は、IDE を再起動します。
JetBrains Marketplace のページからインストールすることもできます。

リポジトリを開く

  • 既にクローンしたリポジトリ: そのフォルダーをプロジェクトとして開きます。プラグインは .diversion フォルダーからリポジトリを見つけます。
  • IDE からクローンする: Rider では File → Open → Get from Version Control、IntelliJ IDEA とその他のほとんどの JetBrains IDE では File → New → Project from Version Control を開きます。Clone Repository ダイアログで、Version control を Diversion に設定し、Repository からリポジトリを選び、Directory を選択して Clone をクリックします。リポジトリが一覧にない場合は、名前を入力します。
サインインしていない場合、IDE に You are not logged in to Diversion と表示されます。dv login でサインインしてから、プロジェクトを開き直してください。

IDE で Diversion を使う

Diversion の操作は、メインメニューの Diversion メニューと、ファイルやフォルダーを右クリックしたときの Diversion サブメニューにあります:
  • Current Workspace Revision: ワークスペースのリポジトリ、ブランチ、コミット。
  • Commit: 変更をコミットします。
  • Reset: 選択したファイルへの変更を破棄します。
  • Branches: ブランチを表示し、チェックアウトします。
  • Resolve Merge Conflicts: 競合のあるマージを開きます。リポジトリに未完了のマージがあるまではグレー表示です。未完了のマージがある場合、IDE に Your repository contains open merges も表示されます。
  • Update Workspace: ワークスペースをブランチの最新コミットに更新します。
  • File Actions: Workspace Changes、Compare with base branch、Compare with Branch…、File History。
  • Browse in Diversion Web App: リポジトリを Web アプリで開きます。
現在のブランチはメインツールバーに表示されます。

各行を変更したユーザーを確認する

ファイルの各行を最後に変更したユーザーを確認するには、エディターの行番号を右クリックして Annotate を選択します。各行に作成者と日付が表示されます。注釈にカーソルを合わせるとコミットが表示されます。プラグインのバージョン 1.4.4 以降が必要です。

Commit ツールウィンドウ

Diversion プラグインが有効な場合、IDE は Commit ツールウィンドウの代わりに Commit ダイアログを使用します。これは、同じプロジェクト内の Git ルートを含め、プロジェクト全体に適用されます。変更は Version Control ツールウィンドウの Local Changes タブに表示されます。 代わりに Commit ツールウィンドウを使用するには:
  1. Help → Find Action を開き、Registry... と入力します。
  2. vcs.force.non.modal.commit を見つけてオンにします。
デフォルトに戻すには、同じ設定をオフにします。